New generation of Imprivata appliances

With every major release of Imprivata’s OneSign product, they also release an updated version of the appliance the product is running on. With the release of Imprivata OneSign & Confirm ID version 6.1 this December, they also released a new generation of the appliance. This version, called generation 3 (G3), is only available as a virtual appliance.

The G3 appliance provides an updated operating system and database, together with the latest security patches.

What does this mean?

Version 6.1 and all subsequent versions of the OneSign product, will only be supported on this new appliance. This means, that if you want to update Imprivata OneSign to version 6.1 or later, you must first migrate to the new G3 appliance. You must purchase the new virtual appliances, along with new licenses, to replace the existing generation 2 appliances.

Generation 2 (G2) appliances will continue to receive patches and hotfixes until their respectively EOL (End of life). This date is set to December 31, 2020 for the virtual and April 30 2019 for the physical appliances. After these dates, Imprivata will no longer provide product updates or patches.

What are the requirements?

The G2 appliances and all Imprivata agents must run at least version 5.2 or later before beginning the migration to G3. The G3 appliance is not backwards compatible with agents operating at 5.1 SP1 or earlier. So, if you haven’t already, it may soon be time to start thinking about upgrading.

Feel free to contact us if you need any assistance with the migration.

Disclaimer: All information on this blog is offered "as is" with no warranty. It is strongly recommended that you verify all information and validate all scripts in isolated test environments before using them in production environments.