The other day I tried to update Workspace Environment Management from 4.5 to 1808. I followed the guidelines provided from Citrix here. Everything went fine with the update of ”Infrastructure Services”, ”Database” and ”Administration Console”, but when I tried to connect to the ”Infrastructure Services” with the ”Administration Console” I faced the error ”Specified Infrastructure Server seems to be offline or have a wrong database configuration. Please check configuration and try again.”.

User-added image

I saw that the connection started to initialize to the database and everything went fine until WEM tried to read ”StorefrontSettings”, then the error came up. I started digging by enabling ”debug mode” in ”WEM Infrastructure Service Configuration”. This saves a log to ”C:\Program Files (x86)\Norskale\Norskale Infrastructure Services\Citrix WEM Infrastructure Service Debug.log” with information and errors connecting to the ”Infrastructure Services”. Unfortunately I did not save the exact error message but it was something like ”Error reading dbo.VUEMStorefrontSettings”.

WEM Debug

I remembered that Citrix added the functionality to point to a StoreFront store in version 4.6.

WEM Storefront

To resolve the issue I restored the database and server to 4.5 and upgraded all the components and database to 4.6, then 4.7 and then finally 1808. After this everything worked as expected.

Seems to me that Citrix forgot to add to create ”dbo.VUEMStorefrontSettings” if not previously existing in 1808…